Startin to work on the Clone Runner (it's PAINTED!)

General Mopar Related Conversation

Moderator: Site Administrators

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Fri Jul 08, 2022 4:51 pm

So I got the wiper pivots and linkage all cleaned up and painted.
July 8th (2).jpg
July 8th (2).jpg (87.89 KiB) Viewed 735 times
July 8th (3).jpg
July 8th (3).jpg (100.75 KiB) Viewed 735 times
July 8th (4).jpg
July 8th (4).jpg (150.16 KiB) Viewed 735 times
July 8th (5).jpg
July 8th (5).jpg (114.27 KiB) Viewed 735 times
Now its time to install the bushing.
Here's the frontside.
July 8th (6).jpg
July 8th (6).jpg (114.36 KiB) Viewed 735 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Fri Jul 08, 2022 4:52 pm

Here's the backside.
July 8th (7).jpg
July 8th (7).jpg (127.51 KiB) Viewed 735 times
Now to flare the bushing in the vise.
July 8th (8).jpg
July 8th (8).jpg (75.01 KiB) Viewed 735 times
Now put it all back together.
July 8th (11).jpg
July 8th (11).jpg (155.4 KiB) Viewed 735 times
July 8th (12).jpg
July 8th (12).jpg (76.01 KiB) Viewed 735 times
July 8th (13).jpg
July 8th (13).jpg (138.51 KiB) Viewed 735 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sat Jul 09, 2022 2:18 pm

I had time today to see if my LEDs that I installed will work.
Hooked up a battery and grounded the dash.
Without LEDs.
July 9th (1).jpg
July 9th (1).jpg (92.33 KiB) Viewed 726 times
And with LED's
July 9th (4).jpg
July 9th (4).jpg (77.06 KiB) Viewed 726 times
July 9th (6).jpg
July 9th (6).jpg (83.14 KiB) Viewed 726 times
July 9th (7).jpg
July 9th (7).jpg (63.54 KiB) Viewed 726 times
July 9th (8).jpg
July 9th (8).jpg (69.69 KiB) Viewed 726 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Aug 07, 2022 2:03 pm

So now that I'm waiting for the dash pad to arrive (arrival date is Sept. 5th) I'm going to regasket the engine.
I pull off the oil pan and I find this inside the sump.
20220722_230216.jpg
20220722_230216.jpg (124.55 KiB) Viewed 556 times
20220722_230225.jpg
20220722_230225.jpg (125.39 KiB) Viewed 556 times
It didn't feel gritty when I rubbed it between my fingertips.

I showed this to my friend that dyno'd the engine. He said to pull the lifters and have a look.
So I did.
Here they are..
20220723_142322.jpg
20220723_142322.jpg (61.08 KiB) Viewed 556 times
20220723_142316.jpg
20220723_142316.jpg (58.49 KiB) Viewed 556 times
If you look closely, there are 3 lifters that were not turning in their bores.
The upper right one - the 5th one down on the right column and the 6th one down on the left column.

My engine guy came over and had a look.
His verdict - change the cam and lifters..... :mad:
This solid cam and lifters are from Hughes engines.

So, a bit of a setback for now as I start looking for another cam.
This one will be an Isky cam.
I prefer them as they are USA made and they have a long history behind them.
The new cam will still be a solid cam - I love the sound of them.

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Sep 04, 2022 1:47 pm

Since I'm in a bit of limbo waiting for the new cam and lifters to arrive I might as well get the engine ready for final paint.
The cylinder heads up till now have still been in bare casting,
Sept 3rd (14).jpg
Sept 3rd (14).jpg (89.96 KiB) Viewed 372 times
Sept 3rd (15).jpg
Sept 3rd (15).jpg (95.08 KiB) Viewed 372 times
so its time to put some primer on them.
Sept 3rd (16).jpg
Sept 3rd (16).jpg (121.51 KiB) Viewed 372 times
Sept 3rd (18).jpg
Sept 3rd (18).jpg (118.85 KiB) Viewed 372 times
Sept 3rd (17).jpg
Sept 3rd (17).jpg (126.24 KiB) Viewed 372 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Sep 04, 2022 1:51 pm

Next, I put the front of the engine pieces back on without gaskets.
Sept 3rd (19).jpg
Sept 3rd (19).jpg (103.61 KiB) Viewed 372 times
Finally lets put the oil pan in place - that way everything will get final paint all together.
Sept 3rd (22).jpg
Sept 3rd (22).jpg (129.99 KiB) Viewed 372 times
Sept 3rd (23).jpg
Sept 3rd (23).jpg (113.14 KiB) Viewed 372 times
Sept 3rd (24).jpg
Sept 3rd (24).jpg (117.75 KiB) Viewed 372 times
Don't worry, I will mask off the crank snout area when the time comes - I'm waiting for my timing cover oil seal to arrive from Rock Auto.

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Fri Sep 09, 2022 8:51 pm

Yesterday I had some time to paint the engine. I used the OER orange paint. I think more paint got on the outside of the can than on the engine..... :mad:
Sept 8th (1).jpg
Sept 8th (1).jpg (76.15 KiB) Viewed 278 times
But it turned out good after 2 cans.
Sept 8th (3).jpg
Sept 8th (3).jpg (163.75 KiB) Viewed 278 times
Sept 8th (4).jpg
Sept 8th (4).jpg (151.1 KiB) Viewed 278 times
Sept 8th (5).jpg
Sept 8th (5).jpg (144.44 KiB) Viewed 278 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Fri Sep 09, 2022 8:53 pm

Earlier today I was able to put the final finish coat of paint using the Mopar orange.
Sept 9th (1).jpg
Sept 9th (1).jpg (94.05 KiB) Viewed 278 times
No issues with the can this time...
Sept 9th (2).jpg
Sept 9th (2).jpg (123.37 KiB) Viewed 278 times
Sept 9th (3).jpg
Sept 9th (3).jpg (119.41 KiB) Viewed 278 times
Sept 9th (4).jpg
Sept 9th (4).jpg (124.83 KiB) Viewed 278 times
Sept 9th (6).jpg
Sept 9th (6).jpg (93.32 KiB) Viewed 278 times

User avatar
sdweatherman
Site Admin
Posts: 782
Joined: Tue Sep 14, 2010 2:36 pm
My Cars: 1971 GY8 Plymouth Satellite Sebring Plus
1971 GB7 Plymouth Satellite Sebring Plus factory Sunroof
1972 EV2 Plymouth Satellite Sebring Plus factory Sunroof
Location: Rapid City, SD
Contact:

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by sdweatherman » Sun Sep 18, 2022 3:20 pm

Looking great!!!
1971 GY8 Plymouth Satellite Sebring Plus
1971 GB7 Plymouth Satellite Sebring Plus w/factory Sunroof
1972 EV2 Plymouth Satellite Sebring Plus w/factory Sunroof

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Wed Sep 21, 2022 12:46 pm

Thanks Scott.
So I just received an e-mail from Summit saying that they can not get the Mopar Performance solid lifters anymore and have refunded my money...WTF! :mad:
They had my order for at least 2 weeks and then now they tell me this?
Anyway, I get on the phone with Crower Cams.
Talked to their tech guy Louie who said he'll have a set of solid lifters that are lightened and have the EDM hole on the face made in 2 to 3 weeks.
I ordered a set right then and there.

In the meantime, I cleared all the crap off my bench and unearthed my 4 speed that's been sitting there waiting patiently.
Here's the clean-up.
Sept 21st (7).jpg
Sept 21st (7).jpg (130.74 KiB) Viewed 151 times
Sept 21st (8).jpg
Sept 21st (8).jpg (128.42 KiB) Viewed 151 times
Now to get it ready for primer.
Sept 21st (12).jpg
Sept 21st (12).jpg (89.62 KiB) Viewed 151 times
Sept 21st (13).jpg
Sept 21st (13).jpg (100.44 KiB) Viewed 151 times
And here's the first coat of primer.
Sept 21st (14).jpg
Sept 21st (14).jpg (86.36 KiB) Viewed 151 times

71Beeper
GTX (RS)
Posts: 605
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Wed Sep 21, 2022 12:48 pm

And now, my next issue.
I find my bellhousing and decided to see if I have the correct bearing retainer......NOT.
Sept 21st (18).jpg
Sept 21st (18).jpg (65.68 KiB) Viewed 150 times
Sept 21st (19).jpg
Sept 21st (19).jpg (55.87 KiB) Viewed 150 times
Does any one know if I can machine the o.d. of the bearing retainer down or open up the hole in the bell housing?

Post Reply