Startin to work on the Clone Runner (it's PAINTED!)

General Mopar Related Conversation

Moderator: Site Administrators

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Apr 03, 2022 2:50 pm

Man, its great having a neighbor that has an industrial size sand blasting cabinet at home.
April 4th (2).jpg
April 4th (2).jpg (72.41 KiB) Viewed 637 times
April 4th (3).jpg
April 4th (3).jpg (60.64 KiB) Viewed 637 times
Got the pieces blasted and ready for paint.
April 3rd (25).jpg
April 3rd (25).jpg (89.67 KiB) Viewed 637 times
April 3rd (24).jpg
April 3rd (24).jpg (83.18 KiB) Viewed 637 times
April 3rd (23).jpg
April 3rd (23).jpg (54.51 KiB) Viewed 637 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Mon May 09, 2022 8:53 pm

So the time has finally come for me to get my engine broken in.
I took it in to a buddy I went to high school with that owns an engine machine shop.
It's located in Fonthill, Ontario.
20220508_114543.jpg
20220508_114543.jpg (142.23 KiB) Viewed 485 times
So Friday night I get the engine off the stand and hooked up to the engine hoist.
20220506_191153.jpg
20220506_191153.jpg (128.83 KiB) Viewed 485 times
20220506_191205.jpg
20220506_191205.jpg (138.21 KiB) Viewed 485 times
Next was to get it in the back of the minivan and onto the cradle.
20220506_193839.jpg
20220506_193839.jpg (110.17 KiB) Viewed 485 times
20220506_193848.jpg
20220506_193848.jpg (119.15 KiB) Viewed 485 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Mon May 09, 2022 8:58 pm

Saturday morning I arrive to his shop.
Unload the engine and get it ready to go into the dyno room.
Here is the dyno room.
20220507_144118.jpg
20220507_144118.jpg (120.16 KiB) Viewed 485 times
Here's the engine mounted to the dyno.
20220507_153335.jpg
20220507_153335.jpg (167.86 KiB) Viewed 485 times
Here is Al checking rocker arm clearance.
20220507_161045.jpg
20220507_161045.jpg (181.6 KiB) Viewed 485 times
We primed the engine to get oil everywhere it needed to be and the result oil pressure was this.
20220507_181918.jpg
20220507_181918.jpg (73.64 KiB) Viewed 485 times
Got the engine fired and put thru it's heat cycles.
That was it for Saturday.

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Mon May 09, 2022 9:03 pm

If any members here read the magazine RPM....Als shop was featured in thier June of 2021 edition.
They had a display of the article in the dyno control room.
20220507_133810.jpg
20220507_133810.jpg (75.56 KiB) Viewed 485 times
20220507_133817.jpg
20220507_133817.jpg (99.89 KiB) Viewed 485 times
20220507_133826.jpg
20220507_133826.jpg (87.77 KiB) Viewed 485 times
Anyway, I come back Sunday and Al has already put the inner valve springs back on the engine.
The inners were left out by the guy who put the engine together because of the solid cam its running it would be easier on the valvetrain during break in.
BUT we have a problem.... :shock:
The underside of the rocker arms hit the valve retainers.
20220508_103001.jpg
20220508_103001.jpg (108.44 KiB) Viewed 485 times
20220508_103008.jpg
20220508_103008.jpg (107.79 KiB) Viewed 485 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Mon May 09, 2022 9:14 pm

So over we go to the machine shop and Al grinds away a relief in the area that was hitting on all of the rocker arms.
20220508_111611.jpg
20220508_111611.jpg (36.57 KiB) Viewed 484 times
Next I put the rockers back on their shafts and line them up with their respective valves.
Al does the rocker clearance once again - .012" on the intakes and .014" on the exhausts.
Then fire up the engine and get the first pull.
20220508_135519.jpg
20220508_135519.jpg (109.21 KiB) Viewed 484 times
423 horse at a touch over 5000rpm. I'm :D
Now, Al wants to put a small phenolic spacer under the 800 Holley. It's about 1/4" thick.
Next pull....
20220508_140933.jpg
20220508_140933.jpg (112.86 KiB) Viewed 484 times
441 horse! a 20 horse increase with just a tiny spacer!
One last thing and tweak the timing to have 37 degrees total.
Bam......
20220508_144555.jpg
20220508_144555.jpg (113.18 KiB) Viewed 484 times
460 horse and 480 ft lbs of torque!
Can't wipe the smile off my face.
It's just a 0.030 over 360 with 340 J heads and a solid cam......
Now its :beer: time.
Attachments
20220508_144625.jpg
20220508_144625.jpg (119.72 KiB) Viewed 484 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun May 15, 2022 7:42 pm

So this weekend I had some time to put together the steering column.
May 15th (1).jpg
May 15th (1).jpg (80.58 KiB) Viewed 426 times
May 15th (4).jpg
May 15th (4).jpg (61.49 KiB) Viewed 426 times
Got a new turn signal unit for as the old one was broken.
May 15th (5).jpg
May 15th (5).jpg (90.63 KiB) Viewed 426 times
Cleaned up the turn stalk with a little mothers polish.
May 15th (8).jpg
May 15th (8).jpg (55.66 KiB) Viewed 426 times
All in all not too bad and not to hard to do.
May 15th (7).jpg
May 15th (7).jpg (132.69 KiB) Viewed 426 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sat May 28, 2022 8:57 pm

I installed the pot coupler today.
May 28th (19).jpg
May 28th (19).jpg (79.42 KiB) Viewed 315 times
May 28th (20).jpg
May 28th (20).jpg (81.07 KiB) Viewed 315 times
May 28th (21).jpg
May 28th (21).jpg (80.77 KiB) Viewed 315 times
May 28th (22).jpg
May 28th (22).jpg (116.72 KiB) Viewed 315 times
And the finished column.......finally. :D
May 28th (23).jpg
May 28th (23).jpg (146.71 KiB) Viewed 315 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sat May 28, 2022 9:01 pm

Moving on to the dash cluster.
I had to make a new gasket.
May 28th (4).jpg
May 28th (4).jpg (84.16 KiB) Viewed 315 times
And fit it like so.
May 28th (8).jpg
May 28th (8).jpg (102.24 KiB) Viewed 315 times
Bought a glove box at a local Mopar swap meet.
May 28th (5).jpg
May 28th (5).jpg (88.94 KiB) Viewed 315 times
Got the proper screws ready.
May 28th (6).jpg
May 28th (6).jpg (60.53 KiB) Viewed 315 times
Put it all together.
May 28th (9).jpg
May 28th (9).jpg (64.4 KiB) Viewed 315 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Jun 05, 2022 4:39 pm

I had some time today to install the dash cluster & wiring harness holder into the dash frame.
June 5th (4).jpg
June 5th (4).jpg (89.41 KiB) Viewed 271 times
June 5th (2).jpg
June 5th (2).jpg (76.36 KiB) Viewed 271 times
June 5th (3).jpg
June 5th (3).jpg (74.67 KiB) Viewed 271 times
June 5th (5).jpg
June 5th (5).jpg (94.61 KiB) Viewed 271 times
June 5th (6).jpg
June 5th (6).jpg (105.02 KiB) Viewed 271 times

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Jun 12, 2022 7:22 pm

Today, I was going to attach the wiring harness to the back of the cluster.
The original harness was hacked by the previous owner when he turned the car into a drag car.
So I bought one from a member on Moparts site.
He assured me that there were no issues with this harness.
Well, I found issues...in the back of the fuse box.
June 12th (7).jpg
June 12th (7).jpg (71.42 KiB) Viewed 173 times
June 12th (10).jpg
June 12th (10).jpg (74.1 KiB) Viewed 173 times
As you can see, the red connection looks like its had some excessive amps going thru it.
And some electrical tape to add an additional wire.
June 12th (11).jpg
June 12th (11).jpg (59.32 KiB) Viewed 173 times
So I dug out my original fuse box which was in better shape.
June 12th (8).jpg
June 12th (8).jpg (59.29 KiB) Viewed 173 times
And switched over all of the connections.
June 12th (26).jpg
June 12th (26).jpg (56.72 KiB) Viewed 173 times
Last edited by 71Beeper on Sun Jun 12, 2022 7:25 pm, edited 1 time in total.

71Beeper
GTX (RS)
Posts: 589
Joined: Mon Dec 27, 2010 5:27 pm
My Cars: 1971 Satellite
Location: Stoney Creek Ontario Canada

Re: Startin to work on the Clone Runner (it's PAINTED!)

Post by 71Beeper » Sun Jun 12, 2022 7:23 pm

Its much better now.
June 12th (27).jpg
June 12th (27).jpg (57.22 KiB) Viewed 173 times

Post Reply